Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 1 day agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square18fedilinkarrow-up163arrow-down18cross-posted to: [email protected]
arrow-up155arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 1 day agomessage-square18fedilinkcross-posted to: [email protected]
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up8arrow-down1·16 hours agoBalls.suck() is the correct syntax.
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up4·16 hours agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·16 hours agoOr I didn’t using the correct naming convention!
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up9·edit-23 hours agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up6·edit-210 hours agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up9·10 hours agoPython port: from ballsucker import suck suck()
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up1·4 hours agoActually, it would be OOP.suck(ddplf.getBalls())
Good, OOP can suck my balls
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
Or I didn’t using the correct naming convention!
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Actually, it would be
OOP.suck(ddplf.getBalls())